ATLAS Data Delayed

Incident Report for Coin Metrics

Resolved

Data is flowing as expected for BCH on ATLAS. This incident resolved on 2026-05-15.
Posted May 18, 2026 - 15:54 UTC

Investigating

ATLAS data for asset BCH is delayed. We are currently investigating this issue, and will provide updates as they are available.
Posted May 15, 2026 - 16:08 UTC
This incident affected: On-Chain Data Products (ATLAS).