Delays for BCH on Atlas v2

Incident Report for Coin Metrics

Resolved

Atlas V2 data for BCH has recovered.
Posted May 16, 2025 - 10:40 UTC

Investigating

Data is currently interrupted for BCH We are actively investigating the issue and can share updates as they are available.
Posted May 15, 2025 - 16:56 UTC
This incident affected: On-Chain Data Products (Network Data Pro).