Data Outage at Bithumb Exchange

Incident Report for Coin Metrics

Resolved

Data from Bithumb recovered and is now flowing as expected. The outage ended at 01:56 UTC and lasted a total of 625 minutes.
Posted 5 days ago. Mar 24, 2025 - 10:23 UTC

Monitoring

Bithumb exchange is currently experiencing an outage impacting spot trades data.
Posted 6 days ago. Mar 23, 2025 - 16:57 UTC
This incident affected: Third Party Data (Market Data Vendor).