Data Outage at MEXC

Incident Report for Coin Metrics

Resolved

Data from MEXC recovered and is now flowing as expected. The outage ended at 08:09 UTC and lasted a total of 26 minutes.
Posted 1 month ago. Apr 15, 2025 - 09:56 UTC

Monitoring

MEXC is currently experiencing an outage impacting spot trades data.

We're continuing to monitor this outage and we will provide updates as they become available.
Posted 1 month ago. Apr 15, 2025 - 07:57 UTC
This incident affected: Third Party Data (Market Data Vendor).