Gemini Trade Delays

Incident Report for Coin Metrics

Update

We are continuing to work on a fix for this issue.
Posted Dec 18, 2025 - 22:03 UTC

Identified

We are continuing to see intermittent trade lags across both data centers for Gemini trading pairs. The symptom is a small number of trades with older trade dates, lagged trades, being sent along with the normally timed trades. For example in the three minute interval from 19:30-19:33 UTC Gemini sent 389 timely trades and 9 that were lagged. Similar patterns are intermittently recurring.

We believe the issue stems from the exchange, and are following up with them accordingly.
Posted Dec 18, 2025 - 21:54 UTC
This incident affects: FFIOMD API (WebSocket API).