Data Outage at MEXC

Incident Report for Coin Metrics

Resolved

Data from MEXC recovered and is now flowing as expected. The outage ended at 11:00 UTC and lasted a total of 180 minutes.

For more information, follow MEXC's incident report here - https://www.mexc.com/support/articles/17827791529648
Posted Aug 25, 2025 - 11:11 UTC

Monitoring

MEXC is currently experiencing an outage impacting futures trade data. We are monitoring this issue and will share updates as they are available.
Posted Aug 25, 2025 - 09:45 UTC
This incident affected: Third Party Data (Market Data Vendor).