Data Outage at Bitstamp

Incident Report for Coin Metrics

Resolved

Data from Bitstamp recovered and is now flowing as expected. The outage ended at 14:40 UTC and lasted a total of 33 minutes.
Posted Mar 19, 2026 - 14:42 UTC

Monitoring

Bitstamp is currently experiencing an outage impacting spot order book and quotes data. We are monitoring the issue and will share updates as we have them.
Posted Mar 19, 2026 - 14:13 UTC
This incident affected: Third Party Data (Market Data Vendor).