Data Outage at MEXC
Incident Report for Coin Metrics
Resolved
Data from MEXC has recovered and is now flowing as expected. The outage ended at 09:52 UTC and lasted a total of 455 minutes.
Posted Jun 05, 2024 - 10:07 UTC
Monitoring
MEXC is currently experiencing an outage impacting futures trades data. We are currently monitoring this situation and we will provide updates as they become available.
Posted Jun 05, 2024 - 08:13 UTC
This incident affected: Third Party Data (Market Data Vendor).