Coin Metrics Website Maintenance
Incident Report for Coin Metrics
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 17:25 UTC
Investigating
The Coin Metrics Website is currently going through maintenance.

We will share updates as they are available.
Posted Oct 03, 2024 - 17:07 UTC
This incident affected: Services (Website).