Bitfinex Exchange Delayed

Incident Report for Coin Metrics

Resolved

Trade data from Bitfinex recovered, and data is now flowing as expected. The outage ended at 17:18 UTC.
Posted Jun 10, 2025 - 17:22 UTC

Investigating

Trade data from Bitfinex is currently delayed. We are investigating the cause of the issue and will share updates as they are available.
Posted Jun 10, 2025 - 16:16 UTC
This incident affected: Market Data Products (Market Data Feed).