Coin Metrics Website Under Maintenance
Incident Report for Coin Metrics
Resolved
The Coin Metrics Website has recovered and is fully operational.
Posted Sep 30, 2024 - 22:34 UTC
Identified
The Coin Metrics Website is currently under maintenance and may experience slight outages.
Posted Sep 30, 2024 - 22:11 UTC
This incident affected: Services (Website).