Data Notice: Toncoin (TON) is being renamed to Gram (GRAM)

Incident Report for Coin Metrics

Resolved

Following the TON community's on-chain governance vote, the native asset of The Open Network has rebranded from Toncoin (TON) to Gram (GRAM). This is a name and ticker change only — the underlying asset, blockchain, and our internal asset identifier are unchanged, and units map 1:1. There is no token swap.

What's changing:
Effective on 2026-06-30 at 17:00 UTC,
- Ticker `ton` → `gram`; display name Toncoin → Gram.
- The legacy `ton` ticker remains an accepted alias and will continue to resolve in API queries.

Impact by data type:
Some data types will preserve history under the GRAM ticker, while others require a historical re-keying to retain history. For data types that require re-keying, no action is being performed at this stage; a migration to unify all series under GRAM is planned for a later date.

- Reference Data (assets, markets, pairs) — ✅ Seamless. Relabeled to GRAM; identifiers move from `*-ton-*` to `*-gram-*`. Legacy `ton` identifiers continue to resolve.
- Market Data (spot trades, candles, quotes, order books) — ✅ Seamless. Continuous history; queryable under both the new and legacy identifiers.
- Principal Market Price — ✅ Seamless. Continuous history.
- Indexes (incl. CMBITM, CMBISCPE) — ✅ Seamless. Index levels continue uninterrupted; GRAM replaces TON as a constituent.
- Reference Rates — ⚠️ Split at cutover. The GRAM series begins 2026-06-30 12:00 UTC; earlier history remains available under the `ton` ticker until the later migration.
- Asset & Market Metrics — ⚠️ Split at cutover. GRAM from 2026-06-30 12:00 UTC onward; pre-rebrand history under `ton`.
- Derivatives (futures, perpetuals) — 🆕 New series. New GRAM contracts appear as venues relist them; existing TON contracts remain as separate historical series.

What you may need to do:
- Update any TON/GRAM display labels in your applications.
- For a continuous Reference Rate or Metrics series spanning the rebrand, query `ton` for data before 2026-06-30 17:00 UTC and `gram` from that time forward.
Posted Jun 30, 2026 - 16:18 UTC
This incident affected: Services (Pro API v4) and Market Data Products (Market Data Feed, CM Prices, Indexes).