Gemini Trade Delays

Incident Report for Coin Metrics

Postmortem

A deeper review confirmed that all affected trades originated from Gemini, with one outlier showing a delay of roughly 60 minutes and about 20 additional trades exceeding our two-minute tolerance, ranging from 2 to 10 minutes. The delay pattern appeared consistently across both data centers, indicating that the issue stemmed upstream from Gemini rather than from our infrastructure.

Posted Dec 18, 2025 - 16:53 UTC

Resolved

We experienced a period of delayed Gemini trades earlier today at 08:36 UTC that lasted for 26.52 minutes. The delay recovered, and data started flowing as expected.
Posted Dec 18, 2025 - 09:54 UTC
This incident affected: FFIOMD API (WebSocket API).