Block by Block Metrics Delayed

Incident Report for Coin Metrics

Resolved

Our block-by-block network data metrics for BTC have recovered.
Posted Feb 11, 2025 - 20:03 UTC

Investigating

Our block-by-block network data metrics are delayed for BTC. We are actively investigating the issue and can share updates as they are available.
Posted Feb 11, 2025 - 18:48 UTC
This incident affected: On-Chain Data Products (Network Data Pro).