Intermittent Delays for Real-time Market Data
Incident Report for Coin Metrics
Resolved
Coin Metrics has resolved the intermittent WebSocket lags that continued to impact our real-time order book data. Our monitoring indicates that real-time order books, trades, and reference rate data are persistently delivering data as expected.
Posted Jan 29, 2024 - 18:58 UTC
Update
Our team is continuing its work on a comprehensive fix to address the intermittent delays in real-time order book data. We will continue to share updates as they become available.
Posted Jan 24, 2024 - 23:21 UTC
Update
Our monitoring shows that our real-time trades and reference rates data are no longer experiencing delays, and are performing as expected.

Though less frequent and severe as before, our real-time order books data continues to experience intermittent delays. Our team is working on a fix, and we will continue to share updates as we have them here.
Posted Jan 19, 2024 - 19:05 UTC
Update
Our monitoring continues to show improved performance for our WebSocket feed. Our team is currently working on further improvements, and will continue to monitor and share updates as we have them.
Posted Jan 16, 2024 - 23:49 UTC
Update
As we continue to monitor this issue, we have seen improvements in the frequency, duration, and severity of these WebSocket lags on our impacted real-time data.

Our team is continuing work toward implementing a comprehensive solution, and we will continue to share updates as we have them here.
Posted Jan 10, 2024 - 23:20 UTC
Monitoring
Our team has implemented a fix, which has improved the reliability of our impacted real-time WebSocket data. We are continuing to monitor the results, and will post updates here as we have them.
Posted Jan 08, 2024 - 20:28 UTC
Investigating
Coin Metrics is currently experiencing intermittent WebSocket lags affecting our real-time market data. From our initial investigation, we have determined that this impacts specifics markets and data sets. Our customers may encounter sporadic real-time data lags for reference rates, trades, quotes, and orderbooks.

Our team will continue to treat this issue with high urgency, investigating and implementing the best path to resolution. We will share any updates as we have them here.
Posted Jan 05, 2024 - 16:26 UTC
This incident affected: Market Data Products (Market Data Feed, CM Prices).